$re = '~/page/\d+~';
$str = 'materials/mods/1.12/page/2';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;