import re
regex = re.compile(r"/page/\d+")
test_str = "materials/mods/1.12/page/2"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)