$re = '/(?:[^x]|\b)(x{3}|x{5})(?:[^x]|\b)/m';
$str = 'xxxxx
xxxx xxxxx xxx
xx xxxxx xx xxx
xxxxxx
xxxaxxxacxxx
axxxaxxxxxuxxxa ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);