re = /(?:[^x]|\b)(x{3}|x{5})(?:[^x]|\b)/m
str = 'xxxxx
xxxx xxxxx xxx
xx xxxxx xx xxx
xxxxxx
xxxaxxxacxxx
axxxaxxxxxuxxxa '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end