$re = '/^[A-Za-z-0-9\_][A-Za-z-0-9\-.\_]*$/m';
$str = 'abra_asd
abra-ham
abraham
abra0ham';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);