re = /^[A-Za-z-0-9\_][A-Za-z-0-9\-.\_]*$/m
str = 'abra_asd
abra-ham
abraham
abra0ham'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end