package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)-.*$`)
var str = `branch:resource-fix-c95e12f`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}