const regex = /(?<volume>vol-[0-9a-z]{17})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<volume>vol-[0-9a-z]{17})', 'gm')
const str = `arn:aws:ec2:us-east-1:0123456789:volume/vol-gg4gggs0svevb3000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}