$re = '/(?<volume>vol-[0-9a-z]{17})/m';
$str = 'arn:aws:ec2:us-east-1:0123456789:volume/vol-gg4gggs0svevb3000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);