use strict;
my $str = 'This is a regex to detect markdown image links of the form 
Here are some markdown links
- [pandoc-fignos](https://github.com/tomduck/pandoc-fignos): Numbers figures and figure references.
The images section will walk you through how to add and reference images so that the pandoc system can properly number them. For example, this [figure](./ch0_1_images.md#fig:ch0_1_images-1) illustrates a VOD curve for a packaged watergel explosive and this [figure](./ch0_1_images.md#fig:ch0_1_images-2) depicts a circular arc.
## [Equations](./ch0_2_equations.md#sec:ch0_2_equations-1)
The equations section will discuss how to use equations and reference them properly. See the [internal energy equation](./ch0_2_equations.md#eq:ch0_2_equations-1) or the [detonation pressure](./ch0_2_equations.md#eq:ch0_2_equations-2)
This string does not contain any links
Here are some image links:
{#fig:id}
{#fig:id tag="B.1"}
{#fig:id tag="B.1"}
{#fig:ch0_1_images-1 width=100%}





















';
my $regex = qr/(?:[!]\[(?P<caption>.*?)\])\((?P<image>.*?)(?P<description>\".*?\")?\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}