// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:[!]\[(?P<caption>.*?)\])\((?P<image>.*?)(?P<description>\".*?\")?\)"#).unwrap();
let string = "This is a regex to detect markdown image links of the form 
Here are some markdown links
- [pandoc-fignos](https://github.com/tomduck/pandoc-fignos): Numbers figures and figure references.
The images section will walk you through how to add and reference images so that the pandoc system can properly number them. For example, this [figure](./ch0_1_images.md#fig:ch0_1_images-1) illustrates a VOD curve for a packaged watergel explosive and this [figure](./ch0_1_images.md#fig:ch0_1_images-2) depicts a circular arc.
## [Equations](./ch0_2_equations.md#sec:ch0_2_equations-1)
The equations section will discuss how to use equations and reference them properly. See the [internal energy equation](./ch0_2_equations.md#eq:ch0_2_equations-1) or the [detonation pressure](./ch0_2_equations.md#eq:ch0_2_equations-2)
This string does not contain any links
Here are some image links:
{#fig:id}
{#fig:id tag=\"B.1\"}
{#fig:id tag=\"B.1\"}
{#fig:ch0_1_images-1 width=100%}





















";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}