package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+[,]\w+\s\w+\(\w+\))`)
var str = `A,Arun Kumar(aa15)A,Aakakn Kumar(aa15)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}