$re = '/(\w+[,]\w+\s\w+\(\w+\))/m';
$str = 'A,Arun Kumar(aa15)A,Aakakn Kumar(aa15)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);