re = /^[^.]*\.[^.]*\K.|\./m
str = '12.34.56.78
.12.34.56.78
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result