package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Mr|Mrs|Ms|Dr|Er)[\..][A-Za-z]+$`)
var str = `Ms._underscore`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}