$re = '/^(Mr|Mrs|Ms|Dr|Er)[\..][A-Za-z]+$/m';
$str = 'Ms._underscore';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);