package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-z0-9áéíóúÁÉÍÓÚ\s]*`)
var str = `This is my test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}