$re = '/[a-zA-z0-9áéíóúÁÉÍÓÚ\s]*/';
$str = 'This is my test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);