import re
regex = re.compile(r"-\n([^(]+)(\(\d\))[|]([^-]+)", flags=re.MULTILINE)
test_str = ("\n"
"--------------------------------------------------------------------------------\n"
"PHYS 11A GEN PHYS-MECHANICS (4)|NOT ARTICULATED \n"
"--------------------------------------------------------------------------------\n"
"PHYS 11B GEN PHYS-HEAT,LIGHT,SOUND (4)|NOT ARTICULATED \n"
"--------------------------------------------------------------------------------\n"
"PHYS 11C GEN PHYS-ELECT,MAG,MOD (4)|NOT ARTICULATED \n"
"--------------------------------------------------------------------------------\n"
"MATH 30 CALCULUS I (4)|MATH 180 Single Variable (4)\n"
" | Calculus I \n"
"--------------------------------------------------------------------------------\n"
"MATH 31 CALCULUS II (4)|MATH 185 Single Variable (4)\n"
" | Calculus II \n"
"--------------------------------------------------------------------------------\n"
"MATH 32 CALCULUS III (4)|MATH 280 Intermediate Calculus (4)\n"
"--------------------------------------------------------------------------------\n"
"MATH 45 DIFFERNTL EQUATN SCI+ENGR (3)|MATH 295 Differential Equations (3)\n"
" | ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")