package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(c|C).*[0-9]$`)
var str = `c1234
c123
c1
cddd
a4884
C3334
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}