$re = '/(c|C).*[0-9]$/m';
$str = 'c1234
c123
c1
cddd
a4884
C3334
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);