#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(?:0?[13578]|1[02])(\/)31)\1|(?:(?:0?[1,3-9]|1[0-2])(\/)(?:29|30)\2))(?:(?:19|[2-9]\d)\d{2})$|^(?:0?2(\/)29\3(?:(?:(?:19|20)(?:0[048]|[2468][048]|[13579][26]))))$|^(?:(?:0?[1-9])|(?:1[0-2]))(\/)(?:0?[1-9]|1\d|2[0-8])\4(?:(?:19|[0-9]\d)?\d{2})$"
Local $sString = "1/1/2019" & @CRLF & _
"2/29/2020" & @CRLF & _
"1/31/00" & @CRLF & _
"2/29/2000" & @CRLF & _
"3/31/2019" & @CRLF & _
"2/29/2020" & @CRLF & _
"7/23/1999" & @CRLF & _
"7/31/1999" & @CRLF & _
"7/28/1999" & @CRLF & _
"7/21/1999" & @CRLF & _
"7/5/1964" & @CRLF & _
"7/21/2000" & @CRLF & _
"2/29/1900" & @CRLF & _
"6/5/1999" & @CRLF & _
"5/5/1999" & @CRLF & _
"4/4/1999" & @CRLF & _
"3/3/1999" & @CRLF & _
"2/2/1999" & @CRLF & _
"2/29/1996" & @CRLF & _
"2/29/2000" & @CRLF & _
"1/1/1954" & @CRLF & _
"1/1/1985" & @CRLF & _
"3/31/2019" & @CRLF & _
"1/29/2010" & @CRLF & _
"10/21/1967"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")