#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/(?(?!jack).*rabbits?.*)"
Local $sString = "0 rabbit" & @CRLF & _
"1 mammal/rabbit" & @CRLF & _
"2 mammal/small fluffy rabbit" & @CRLF & _
"3 mammal/lop-eared rabbit" & @CRLF & _
"4 mammal/many rabbits" & @CRLF & _
"5 mammal/jack rabbit"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")