re = /\/(?(?!jack).*rabbits?.*)/
str = '0 rabbit
1 mammal/rabbit
2 mammal/small fluffy rabbit
3 mammal/lop-eared rabbit
4 mammal/many rabbits
5 mammal/jack rabbit'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end