package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)([a-z0-9\-\_.]+)?(\/[a-z0-9\-.]+)?(:[\w\.\-\_]+)?$`)
var str = `gitea/gitea:1.13.7
kiwigrid/k8s-sidecar:0.1.209
registry1.dso.mil/ironbank/opensource/docker/registry-v2:2.7.1
registry.opensource.zalan.do/acid/logical-backup:v1.7.0
docker.io/dpage/pgadmin4:5.5
registry1.dso.mil/ironbank/opensource/minio/minio:RELEASE.2021-08-31T05-46-54Z
ghcr.io/stefanprodan/podinfo:6.0.0
ghcr.io/stefanprodan/podinfo:6.0.0-v2
k3d-cluster.localhost/defenseunicorns/zarf-agent
localhost:5000/some-user/some-cool-image
localhost:5000/someuser/some-cool-image:tag
127.0.0.1:443/some-user/some-cool-image:tag
127.0.0.1/some_user/some-cool-image:tag
https://127.0.0.1:443/some-user/some-cool-image:tag
https://127.0.0.1/some-user/some-cool-image:tag
defenseunicorns/zarf-game:multi-tile-dark
/defenseunicorns/zarf-game:multi-tile-dark
paas.docker-registry:443/ironbank/opensource/goharbor/chartmuseum:v2.5.1
paas-docker.registry:443/ironbank/opensource/goharbor/chartmuseum:v2.5.1
paas-docker-registry:443/ironbank/opensource/goharbor/chartmuseum:v2.5.1
awesome.nexus.com/repository/docker/ironbank/opensource/goharbor/chartmuseum:v2.5.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}