# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?im)([a-z0-9\-\_.]+)?(\/[a-z0-9\-.]+)?(:[\w\.\-\_]+)?$"
test_str = ("gitea/gitea:1.13.7\n"
"kiwigrid/k8s-sidecar:0.1.209\n"
"registry1.dso.mil/ironbank/opensource/docker/registry-v2:2.7.1\n"
"registry.opensource.zalan.do/acid/logical-backup:v1.7.0\n"
"docker.io/dpage/pgadmin4:5.5\n"
"registry1.dso.mil/ironbank/opensource/minio/minio:RELEASE.2021-08-31T05-46-54Z\n"
"ghcr.io/stefanprodan/podinfo:6.0.0\n"
"ghcr.io/stefanprodan/podinfo:6.0.0-v2\n"
"k3d-cluster.localhost/defenseunicorns/zarf-agent\n"
"localhost:5000/some-user/some-cool-image\n"
"localhost:5000/someuser/some-cool-image:tag\n"
"127.0.0.1:443/some-user/some-cool-image:tag\n"
"127.0.0.1/some_user/some-cool-image:tag\n"
"https://127.0.0.1:443/some-user/some-cool-image:tag\n"
"https://127.0.0.1/some-user/some-cool-image:tag\n"
"defenseunicorns/zarf-game:multi-tile-dark\n"
"/defenseunicorns/zarf-game:multi-tile-dark\n"
"paas.docker-registry:443/ironbank/opensource/goharbor/chartmuseum:v2.5.1\n"
"paas-docker.registry:443/ironbank/opensource/goharbor/chartmuseum:v2.5.1\n"
"paas-docker-registry:443/ironbank/opensource/goharbor/chartmuseum:v2.5.1\n"
"awesome.nexus.com/repository/docker/ironbank/opensource/goharbor/chartmuseum:v2.5.1")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.