using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"GROUP BY (.*?[^,]) ";
string input = @"GROUP BY id,asd, asddd, adfasd order id asc;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}