$re = '/GROUP BY (.*?[^,]) /';
$str = 'GROUP BY id,asd, asddd, adfasd order id asc;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);