re = /\s\S*/m
str = 'I am too high for our ladder. I am two hi for our ladder. I am to high four hour ladder'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end