#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(en\/)?property\/[A-Яa-я0-9\-_\/]+?([\d]+)(.*)$"
Local $sString = "en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v-9/" & @CRLF & _
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/9/" & @CRLF & _
"en/property/rotterdam-centrum/appartment/lorem-ipsum-dolor-sit-amet/9" & @CRLF & _
"en/property/lorem-ipsum-dolor-sit-amet-9/" & @CRLF & _
"en/property/lorem-ipsum-dolor-sit-amet/v9/" & @CRLF & _
"en/property/lorem-ipsum-dolor-sit-amet/v-9/" & @CRLF & _
"en/property/lorem-ipsum-dolor-sit-amet/v-9" & @CRLF & _
"en/property/rotterdam/apartment/branch/lorem-ipsum-dolor-sit-amet-9/" & @CRLF & _
"en/property/rotterdam/lorem-ipsum-dolor-sit-amet-9/" & @CRLF & _
"en/property/rotterdam/lorem-ipsum-dolor-sit-amet-9434343/" & @CRLF & _
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v-243249/" & @CRLF & _
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v2342349/" & @CRLF & _
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/243249/" & @CRLF & _
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v-9/" & @CRLF & _
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v-9/?test=1" & @CRLF & _
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v-9/test/one/?success=3" & @CRLF & _
"en/property/rotterdam/apartment/2-rooms/lorem-ipsum-dolor-sit-amet/v-9/blah/1234/blahh/55555/?sass=123" & @CRLF & _
"en/property/rotterdam/appartment/lorem-ipsum-dolor-sit-amet/9234234" & @CRLF & _
"en/property/rotterdam/lorem-ipsum-dolor-sit-amet/9234234" & @CRLF & _
"en/property/lorem-ipsum-dolor-sit-amet/9234234" & @CRLF & _
"en/property/9234234" & @CRLF & _
"en/property/rotterdam/appartment/lorem-ipsum-dolor-sit-amet/9/test/132?algo=123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")