# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(en\/)?property\/[A-Яa-я0-9\-_\/]+?([\d]+)(.*)$"
test_str = ("en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v-9/\n"
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/9/\n"
"en/property/rotterdam-centrum/appartment/lorem-ipsum-dolor-sit-amet/9\n"
"en/property/lorem-ipsum-dolor-sit-amet-9/\n"
"en/property/lorem-ipsum-dolor-sit-amet/v9/\n"
"en/property/lorem-ipsum-dolor-sit-amet/v-9/\n"
"en/property/lorem-ipsum-dolor-sit-amet/v-9\n"
"en/property/rotterdam/apartment/branch/lorem-ipsum-dolor-sit-amet-9/\n"
"en/property/rotterdam/lorem-ipsum-dolor-sit-amet-9/\n"
"en/property/rotterdam/lorem-ipsum-dolor-sit-amet-9434343/\n"
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v-243249/\n"
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v2342349/\n"
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/243249/\n"
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v-9/\n"
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v-9/?test=1\n"
"en/property/rotterdam/apartment/lorem-ipsum-dolor-sit-amet/v-9/test/one/?success=3\n"
"en/property/rotterdam/apartment/2-rooms/lorem-ipsum-dolor-sit-amet/v-9/blah/1234/blahh/55555/?sass=123\n"
"en/property/rotterdam/appartment/lorem-ipsum-dolor-sit-amet/9234234\n"
"en/property/rotterdam/lorem-ipsum-dolor-sit-amet/9234234\n"
"en/property/lorem-ipsum-dolor-sit-amet/9234234\n"
"en/property/9234234\n"
"en/property/rotterdam/appartment/lorem-ipsum-dolor-sit-amet/9/test/132?algo=123")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.