import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[a-zA-Z0-9._]{4,10}$)(?!.*[_.]{2})[A-Za-z]+(?:[_.][a-zA-Z0-9]+)?$";
final String string = "username\n"
+ "user_name\n"
+ "user.name\n"
+ "uname_123\n\n"
+ "username_123\n"
+ "123_userna";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}