re = /^(?=[a-zA-Z0-9._]{4,10}$)(?!.*[_.]{2})[A-Za-z]+(?:[_.][a-zA-Z0-9]+)?$/m
str = 'username
user_name
user.name
uname_123
username_123
123_userna'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end