#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-z0-9]+[\.|\-]{0,1}[a-z0-9](.[a-z0-9]{2,})+)$"
Local $sString = "xxx.sub-domena.vege.love" & @CRLF & _
"" & @CRLF & _
"sub-domena.sub-do-main.dom-ain.com.pl" & @CRLF & _
"" & @CRLF & _
"sub-domena.sub-do-main.dom-ain.co" & @CRLF & _
"" & @CRLF & _
"sub-domena.sub-do-main.dom-ain.vege.love" & @CRLF & _
"" & @CRLF & _
"vege.love" & @CRLF & _
"" & @CRLF & _
"Maxi.Max@" & @CRLF & _
"" & @CRLF & _
"Max-Wielk.Amiu-Max@" & @CRLF & _
"maxiu-maxiu-max@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")