$re = '/^([a-z0-9]+[\.|\-]{0,1}[a-z0-9](.[a-z0-9]{2,})+)$/m';
$str = 'xxx.sub-domena.vege.love
sub-domena.sub-do-main.dom-ain.com.pl
sub-domena.sub-do-main.dom-ain.co
sub-domena.sub-do-main.dom-ain.vege.love
vege.love
Maxi.Max@
Max-Wielk.Amiu-Max@
maxiu-maxiu-max@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);