using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\W+\d*";
string input = @"((x0+(2.0^x))/(21.1-x0))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}