$re = '/\W+\d*/m';
$str = '((x0+(2.0^x))/(21.1-x0))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);