const regex = /https?:\/\/[a-z0-9.-]+\.[a-z]{2,3}(\/\S*?(?=\.*(?:\s|$)))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/[a-z0-9.-]+\\.[a-z]{2,3}(\\\/\\S*?(?=\\.*(?:\\s|$)))?', 'gm')
const str = `Example text... https://example.com/site. More text here...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}