re = /https?:\/\/[a-z0-9.-]+\.[a-z]{2,3}(\/\S*?(?=\.*(?:\s|$)))?/m
str = 'Example text... https://example.com/site. More text here...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end