$re = '~/(\w+)/[-a-z]+?/?(?:\?.*?\s|\s|$)~m';
$str = 'http://www.test.com/newyork/class-schedule
http://www.test.com/location/newyork/class-schedule
http://www.test.com/location/newyork/training';
$subst = "http://www.test.com/location/$1/class-schedule";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;