// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/(\w+)/[-a-z]+?/?(?:\?.*?\s|\s|$)").unwrap();
let string = "http://www.test.com/newyork/class-schedule
http://www.test.com/location/newyork/class-schedule
http://www.test.com/location/newyork/training";
let substitution = "http://www.test.com/location/$1/class-schedule";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}