$re = '/\b\d{2}|\d{2}\b/';
$str = ' - character30 wordstart
- wordstart 30character
- the number 30 is here
But do not want to on the following:
- character30character';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);