import Foundation
let pattern = #"\b\d{2}|\d{2}\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
- character30 wordstart
- wordstart 30character
- the number 30 is here
But do not want to on the following:
- character30character
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)