$re = '/^(?<type>[^~]+).+~ (?<app>.+)/m';
$str = 'Problem~APP OPS TechOps Open Systems~Medium~ 18410_GIVIS~KBA00128046';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);