re = /^(?<type>[^~]+).+~ (?<app>.+)/m
str = 'Problem~APP OPS TechOps Open Systems~Medium~ 18410_GIVIS~KBA00128046'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end