package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([0-5]{1}\d{1})$|^(\d{1})$`)
var str = `
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}