$re = '/^([0-5]{1}\d{1})$|^(\d{1})$/';
$str = '
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);