import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)json:(?!.*json:.*totalCount.*).*?totalCount.*?(?=\\[2)";
final String string = "[2018-12-10 06:30:44]JSON回调处理--->>> 同步运动数据 [2018-12-10 06:30:44]同步运动健康数据json:{ \"day\" : 10, \"items\" : [ { \"activeTime\" : 5, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 },\n"
+ "{ \"activeTime\" : 0, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 }, { \"activeTime\" : 0, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 } ], \"month\" : 12, \"startTime\" : 0, \"timeSpace\" : 15, \"totalActiveTime\" : 81, \"totalCalory\" : 0, \"totalDistance\" : 0, \"totalCount\" : 0, \"year\" : 2018 } \n"
+ "[2018-12-10 06:30:44]同步运动健康数据items.sise()=96\n"
+ "[2018-12-10 06:30:38]..再同步健康数据... \n"
+ "[2018-12-10 06:30:44]JSON回调处理--->>> 同步运动数据 [2018-12-10 06:30:44]同步运动健康数据json:{ \"day\" : 10, \"items\" : [ { \"activeTime\" : 5, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 },\n"
+ "{ \"activeTime\" : 0, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 }, { \"activeTime\" : 0, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 } ], \"month\" : 12, \"startTime\" : 0,\n"
+ "\"timeSpace\" : 15, \"totalActiveTime\" : 81, \"totalCalory\" : 0, \"totalDistance\" : 0, \"StepCount\" : 0, \"year\" : 2018 } \n"
+ "[2018-12-10 06:30:44]同步运动健康数据items.sise()=96 \n"
+ "[2018-12-10 06:30:38]..再同步健康数据... ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}