# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)json:(?!.*json:.*totalCount.*).*?totalCount.*?(?=\[2)"
test_str = ("[2018-12-10 06:30:44]JSON回调处理--->>> 同步运动数据 [2018-12-10 06:30:44]同步运动健康数据json:{ \"day\" : 10, \"items\" : [ { \"activeTime\" : 5, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 },\n"
"{ \"activeTime\" : 0, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 }, { \"activeTime\" : 0, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 } ], \"month\" : 12, \"startTime\" : 0, \"timeSpace\" : 15, \"totalActiveTime\" : 81, \"totalCalory\" : 0, \"totalDistance\" : 0, \"totalCount\" : 0, \"year\" : 2018 } \n"
"[2018-12-10 06:30:44]同步运动健康数据items.sise()=96\n"
"[2018-12-10 06:30:38]..再同步健康数据... \n"
"[2018-12-10 06:30:44]JSON回调处理--->>> 同步运动数据 [2018-12-10 06:30:44]同步运动健康数据json:{ \"day\" : 10, \"items\" : [ { \"activeTime\" : 5, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 },\n"
"{ \"activeTime\" : 0, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 }, { \"activeTime\" : 0, \"calory\" : 0, \"distance\" : 0, \"stepCount\" : 0 } ], \"month\" : 12, \"startTime\" : 0,\n"
"\"timeSpace\" : 15, \"totalActiveTime\" : 81, \"totalCalory\" : 0, \"totalDistance\" : 0, \"StepCount\" : 0, \"year\" : 2018 } \n"
"[2018-12-10 06:30:44]同步运动健康数据items.sise()=96 \n"
"[2018-12-10 06:30:38]..再同步健康数据... ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.