using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>) \b|\b (?=<)";
string substitution = @"";
string input = @"<span class=""sitestr""> googleblog.com </span></a>"" ) ""</span><a/>"" | ""<a>
<span class=""sitestr""> googleblog.com </span></a> ) </span><a/> | <a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}